#33 Error: haskell-lsp:no handler for

Closed
opened 2 weeks ago by calicojack · 6 comments
Michael commented 2 weeks ago

Hello

I'm using vhdl-tool with the VSCode plugin. I'm seeing the following error message all the time:

[Error - 10:37:05 AM] haskell-lsp:no handler for. Object (fromList [("jsonrpc",String "2.0"),("params",Object (fromList [("id",Number 28.0)])),("method",String "$/cancelRequest")])

It seems that for a while everything (Symbol extraction, Go To...) works fine. But after some time and opening a couple of files, it stops working. The Outline window just shows "Loading document symbols for ..."

best regards Michael

Hello I'm using vhdl-tool with the VSCode plugin. I'm seeing the following error message all the time: `[Error - 10:37:05 AM] haskell-lsp:no handler for. Object (fromList [("jsonrpc",String "2.0"),("params",Object (fromList [("id",Number 28.0)])),("method",String "$/cancelRequest")])` It seems that for a while everything (Symbol extraction, Go To...) works fine. But after some time and opening a couple of files, it stops working. The Outline window just shows "Loading document symbols for ..." best regards Michael
vhdl-tool commented 2 weeks ago
Owner

I uploaded the wrong file for the 0.10 release. That's fixed now. If you re-download, the error messages should be gone.

The bug where it just stops working is strange. Perhaps VSCode is overwhelmed with error messages. Let me know if the latest binary fixes that.

Thanks!

I uploaded the wrong file for the 0.10 release. That's fixed now. If you re-download, the error messages should be gone. The bug where it just stops working is strange. Perhaps VSCode is overwhelmed with error messages. Let me know if the latest binary fixes that. Thanks!
Michael commented 2 weeks ago
Poster

Thank you for the fast answer. The problems are solved with the new binary version. :)

Thank you for the fast answer. The problems are solved with the new binary version. :)
Michael commented 2 weeks ago
Poster

Ok sadly I still have the issue that the vhdl-tool stops working after a while. From the Trace I can see, that the VSCode extension doesn't receive any answer anymore. Before that happens, a Problem with the /tmp/log file is reported. I added a except of the trace log as a file.

Ok sadly I still have the issue that the vhdl-tool stops working after a while. From the Trace I can see, that the VSCode extension doesn't receive any answer anymore. Before that happens, a Problem with the /tmp/log file is reported. I added a except of the trace log as a file.
vhdl-tool commented 2 weeks ago
Owner

Thanks for the info about the log.

Possibly, it's running out of space on /tmp after a lot of editing. It's not supposed to log to /tmp by default but for some reason it does. I have been able to reproduce that. I'm working on a fix.

Thanks for your bug reports and patience.

Thanks for the info about the log. Possibly, it's running out of space on /tmp after a lot of editing. It's not supposed to log to /tmp by default but for some reason it does. I have been able to reproduce that. I'm working on a fix. Thanks for your bug reports and patience.
vhdl-tool commented 1 week ago
Owner

The latest version, 0.11, does not log to /tmp by default. Let me know if that fixes things.

The latest version, 0.11, does not log to /tmp by default. Let me know if that fixes things.
Michael commented 1 week ago
Poster

Great, I will try the new version for some time to check if the problem is solved

Great, I will try the new version for some time to check if the problem is solved
Sign in to join this conversation.
No Label
No Milestone
No assignee
2 Participants
Loading...
Cancel
Save
There is no content yet.